Adding the plug-in to your existing app

Installing the Bluedot plug-in

Run the following standard command to add the plug-in to your Cordova app:

cordova plugin add bluedot-plugin

Supported Platforms

Bluedot plug-in supports iOS and Android platforms.  These can be added to your app with the following commands:

cordova platform add ios
cordova platform add android

Provided wrappers

To assist in getting your app up and running as quickly as possible, Javascript function wrappers are provided in the Bluedot plug-in repository at the following location:

<plug-in>/js/bdFunctions.js

These functions provide sample code for the SDK functionality that can be utilised in their current form and expanded upon as the requirements of your app grow.  This file can be copied to your app’s Javascript source directory and included in the <head></head> tags of your app’s index.html:

<script type="text/javascript" src="<Javascript source directory>/bdFunctions.js"></script>

In summary, the functions relate to an HTML page that contains the following:

  • A text area with an id of "statusText"
    This text area is updated with the responses from the Bluedot Point SDK.
  • A button with an id of "authenticateButton"
    This will call the doAuthenticate() function with the following constants that are set at the top of the bdFunctions.js file:

    • username
    • apiKey
    • packageName
  • A button with an id of "logOutButton"
    This will call the doLogOut() function

 

These functions are representative and should be adjusted for the use of your particular app.

iOS Updates

There are some differences between a default Xcode project and the project requirements for an app running Point SDK.  In summary:

  • Point SDK does not enforce Bitcode.
  • The minimum supported version of iOS for Cordova is 6.0 but Point SDK supports 8.0 and above.
  • There are required UIApplicationDelegate methods that are not implemented in the default Cordova AppDelegate that are required by Point SDK.

Updating the Xcode Project

In the Xcode Project

  • Use of Bitcode must be set to NO in Build Settings.
  • Minimum supported iOS version should be set to 8.0 in General.

In the AppDelegate.m file

  • The following methods must be added to the AppDelegate should they not already be there:
- (void)applicationWillEnterForeground:(UIApplication *)application
{
    // This method implementation must be present in AppDelegate
    // when integrating Bluedot Point SDK v1.x, even if it is empty.
}
  
- (void)applicationDidEnterBackground:(UIApplication *)application
{
    // This method implementation must be present in AppDelegate
    // when integrating Bluedot Point SDK v1.x, even if it is empty.
}
  
- (void)applicationWillResignActive:(UIApplication *)application
{
    // For iOS9 and above, this method implementation must be present in AppDelegate
    // when integrating Bluedot Point SDK v1.x, even if it is empty.
}
Created by Bluedot DevOps on January 16, 2018

Start the discussion